Icon of program: FrontRow Conductor

FrontRow Conductor for iOS

By FrontRowFreeUser Rating

Key Details of FrontRow Conductor

  • The FrontRow Conductor app is the mobile companion to the FrontRow Conductor system, an IP Paging, Intercom, Bells, and Emergency Alerts solution.
  • Last updated on January 31, 2020
  • There have been 1 updates
  • Virus scan status:

    Clean (it's extremely likely that this software program is clean)


Enlarged image for FrontRow Conductor

Developer's Description

The FrontRow Conductor app is the mobile companion to the FrontRow Conductor system, an IP Paging, Intercom, Bells, and Emergency Alerts solution.

The FrontRow Conductor app is the mobile companion to the FrontRow Conductor system, an IP Paging, Intercom, Bells, and Emergency Alerts solution for K-12 schools and community colleges.

NOTE: Requires the FrontRow Conductor server and an ezRoom or Juno Connect campus installation in order to use.

With this app, administrators can activate any function they can program into Conductor, from anywhere on the campus wireless network. The Conductor system keeps schools running efficiently and safely with campus digital audio bells, music, and announcements. Now principals can have a new way to keep students and faculty informed, whether its a routine task, a drill, or an urgent situation.

Play music across the school

Trigger a lockdown, complete with audio, digital signage control, and emails

Initiate a pre-recorded announcement

Configure up to six buttons, each with a separate action, text, and color. You can even use Emoji in the button labels.

If for any reason the server cannot be reached, the app automatically falls back into dial-in mode, linking you to the Conductor system from anywhere using standard cellular lines and touch tone activation.

Learn more at www.gofrontrow.com


Explore More


Full Specifications

GENERAL
Release
January 31, 2020
Latest update
January 31, 2020
Version
1.2
OPERATING SYSTEMS
Platform
iOS
Operating System
iOS 12.1.2
Additional Requirements
Requires iOS 10.3 or later. Compatible with iPhone, iPad, and iPod touch.
POPULARITY
Total Downloads
0
Downloads Last Week
0

Related Software