SiteLauncher

A newer version of SiteLauncher is available.

Or, Learn More About SiteLauncher
CNET Editors' Rating 4.5 stars

Outstanding

Average User Rating stars

out of 14 user reviews

Back to product review

Full user review

  • 1.0 stars

    "Why Only For Outdated Version of Firefox ?"

    January 8, 2009  |   By RanMan1255

    Pros

    Can't think of a Pro for a addon/extension that will only work with an outdated version of Firefox. Current version of Firefox is v3.0.5 and v3.1 is just around the corner. Maybe works good with Firefox 2, but not good enough to down grade Firefox.

    Cons

    Apparently only compatible with outdated version of Firefox.

    Summary

    I know that there are a lot of users still using Firefox 2, but at some point it is time to move on. Maybe the software author will update this addon/extension to work with Firefox 3 in the future. In the meantime, I will continue to use "Tidy Favorites" which is a richly featured bookmark program that is an external program, not an addon or extension, but works seamlessly with Firefox.

    Reply to this review

    Was this review helpful? (0) (1)

1 reply to this review

  • Reply by J-Do on January 8, 2009

    I'm using it on version 3.0.5 without a hiccup. We've corrected the requirements section--the extension should work on v3.1 and beyond, once they come out.

Submit your reply

Submit

The posting of advertisements, profanity, or personal attacks is prohibited.
Click here to review our site terms of use.

cancel

Add Your Review

Log in or create an account to post a review.
You are logged in as . Please submit your review for SiteLauncher 0.9.3
Add Your Review

The posting of advertisements, profanity, or personal attacks is prohibited.
Click here to review our site terms of use.

E-mail this review

Submit cancel

Report offensive content

If you believe this comment is offensive or violates the CNET's Site Terms of Use, you can report it below (this will not automatically remove the comment). Once reported, our staff will be notified and the comment will be reviewed.

Select type of offense:

Offensive: Sexually explicit or offensive language
Spam: Advertisements or commercial links
Disruptive posting: Flaming or offending other users
Illegal activities: Promote cracked software, or other illegal content
Submit cancel

Error

close

ERROR MESSAGE

If you think this is an error, please contact CNET TechTracker Support for further assistance.

Ok

Running Request

close

loading

Smart Install Software

close

CNET TechTracker will now automatically install software without requiring further action by you. (Note: This feature automatically accepts associated EULAs and third party applications on your behalf.)

You have selected the following software to Smart Install:

CNET TechTracker will attempt to install this software without interrupting you again. If an application requires manual installation, CNET TechTracker will download the installer and prompt you to take further action.

Proceed with Smart Install?

Confirm Standard Install Cancel